Results 1 to 3 of 3

Thread: Attachment problems...

  1. #1
    Join Date
    May 2017
    Posts
    20

    Default Attachment problems...

    Lock N Load attachment doesnít seem to work very well with PALS. Pouch ends up pinched or pulled in odd directions leaving it misshapen. Am I doing something wrong? If not, this manner of attachmeant isnít so good.

    MALICE clips are ideal with PALS and work great, but... when releasing the clip, how can I use that wonít marr and damage the clip? Iíve been using a dull butter knife but even so, the soft rubber becomes marred and damaged. In the service all of our cordura pouched had fabric on the back with snaps.

    Thanks in advance for any information...

  2. #2
    Join Date
    Mar 2013
    Location
    Littleton, Co
    Posts
    2,090

    Default Re: Attachment problems...

    Hi Buncheong,

    Im a bit confused by what you are describing. Can you provide a picture of what you mean?

  3. #3
    Join Date
    Aug 2015
    Location
    Littleton, CO
    Posts
    230

    Default Re: Attachment problems...

    The PALS on the belt aren't perfectly spaced to spec (you will notice that the spacing is wider towards the back than the front), so you may get a little slack that is pretty much unnoticeable, but on standard PALS the LnL attachment system is far more convenient than MALICE clips. I have had no problems with slack and misshapen pockets. The only problem I have had , which would also occur with MALICE clips is that when a pocket is on the side of my bag and the bag is extremely full then the attachment points are pulled very tight. If there's too much slack try going from the opposite side of the PALS (ie come from the bottom on the bottom attachments or top on the top attachments).

    As far as malice clips go, there is a small slot on the back that you can push a knife or something similar through to push up the tab rather than prying it. You may get a small amount of wear over time, but they are cheap and easy to replace unlike the sewn-in fabric snap backs on some USGI stuff.
    Last edited by lineman78; 10-31-2017 at 10:51 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •